Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6 и имеет 2 знака в дробной части.
Ответы на вопрос
Ответил Sergey22334
0
program sluch_chislo;
uses crt;
var
i : real;
a : string;
begin
clrscr;
Randomize;
writeln ('Для вывода следующего числа нажмите Enter');
writeln ('Для выхода из программы введите 0 и нажмите Enter');
while (true) do
begin
i := random(101)/100+5; //Случайное число от 5.00 до 6.00 включительно
writeln (i:6:2);
readln (a);
if a='0' then exit;
end;
end.
uses crt;
var
i : real;
a : string;
begin
clrscr;
Randomize;
writeln ('Для вывода следующего числа нажмите Enter');
writeln ('Для выхода из программы введите 0 и нажмите Enter');
while (true) do
begin
i := random(101)/100+5; //Случайное число от 5.00 до 6.00 включительно
writeln (i:6:2);
readln (a);
if a='0' then exit;
end;
end.
Приложения:
Ответил Аноним
0
Так что предлагаю на сём остановиться.
Ответил Sergey22334
0
Как раз к лингвистам я и апеллирую. Техническая образованность (я имею в виду авторов документации к Паскалю) не снимает ответственности за знание языка общения людей.
Ответил Sergey22334
0
Пусть скажут своё слово лингвисты. А не модераторы.
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
begin
Writeln((Random(101)+500)/100)
end.
begin
Writeln((Random(101)+500)/100)
end.
Приложения:
Новые вопросы