Составить программу для решения задачи:
"Ввести число, обозначающее размер одной фотографии в Мбайтах. Определить, сколько фотографий поместится на флэш-карту объёмом 2 Гбайта."
Язык программирования: Pascal
Ответы на вопрос
Ответил Аноним
0
1. С вещественными числами
var
k:real;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',
Trunc(2*1024/k))
end.
Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626
2. С целыми числами
var
k:integer;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.
Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
var
k:real;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',
Trunc(2*1024/k))
end.
Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626
2. С целыми числами
var
k:integer;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.
Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
Новые вопросы
Математика,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Физика,
9 лет назад
Алгебра,
9 лет назад