Информатика, вопрос задал polinastar12 , 7 лет назад

Составить программу для подсчета суммы всех натуральных чисел кратных 3 в промежутке от a до b.Значение a и b задаются пользователем.
(Пример работы программы: a=10; b=16. Их сумма 27)

Ответы на вопрос

Ответил hello93
0

P.S программа написана для Pascal.

program summa;

var  

 a, b, s : integer;

begin

 writeln('Введите число a=');

 read(a);

 writeln('Введите число b=');

 read(b);

 s:=0;

for a:=a to b do  

 if a mod 3=0 then  

   s:=s+a;

 writeln('Сумма: ',s);

end.  


Новые вопросы