составить программу для паскаля.1)Определить количество трехзначных чисел сума цифр которых равна числу N.2)Дано натуральное число N.Составить программу меняющихся местами первую и последнюю цифру.
Ответы на вопрос
Ответил igor9997799
0
1)
var s: string;
i, n,c: integer;
begin
read(n);
for i := 100 to 999 do
begin
s:=inttostr(i);
c:=(strtoint(s[1])+strtoint(s[2])+strtoint(s[3]));
if(n=c)then writeln(s);
end;
end.
2)
var s: string;
begin
read(s);
swap(s[1],s[s.Length]);
write(s);
end.
var s: string;
i, n,c: integer;
begin
read(n);
for i := 100 to 999 do
begin
s:=inttostr(i);
c:=(strtoint(s[1])+strtoint(s[2])+strtoint(s[3]));
if(n=c)then writeln(s);
end;
end.
2)
var s: string;
begin
read(s);
swap(s[1],s[s.Length]);
write(s);
end.
Новые вопросы
История,
2 года назад
Физика,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад