Информатика, вопрос задал dikor48 , 2 года назад

Составить программу для нахождения среднего значения чисел последовательности кратных 6. Всего в последовательности 12 натуральных чисел, значения которых вводятся с клавиатуры.

Нужно найти на языке Pascal​

Ответы на вопрос

Ответил programmermisha17
0

Ответ:

program task;

const n = 12;

var

   a: array [1..n] of integer;

   res, min, i : integer;

   

begin

 res := 0;

 for i:=1 to 12 do

   readln (a[i]);

 for i:= 2 to 31 do

   if ( a[i] mod 6 = 0 ) then

       res := res + a[i];

   

 writeln('Sum: ');

 write(res);

end.

Объяснение:

Новые вопросы