Составить программу для нахождения произведения модулей отрицательных значений функции
у= sin2x-0.5, где х∈[0,10], Δx=0,1 и суммы ее положительных значений.
Ответы на вопрос
Ответил toxef47289
1
Ответ:
const
cMinX: Single = 0;
cMaxX: Single = 10;
cDelta: Single = 0.1;
var
y, x: Single;
sum, mul: Single;
begin
sum := 0;
mul := 1;
x := cMinX;
repeat
y = Sin(2*x)-0.5;
if y > 0 then
sum := sum + y;
if y < 0 then
mul := mul*Abs(y);
until x > cMaxX;
Writeln(sum);
Writeln(mul);
end;
Объяснение:
lik18da:
хм почему то программа не запускается не с скачанного паскаля, не с онлайн
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад