Составить программу для нахождения НОД десяти двухзначных чисел. Паскаль.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
function gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var a:=ReadArrInteger('Введите 10 натуральных двухзначных чисел:',10);
var g:=gcd(a[0],a[1]);
for var i:=2 to 9 do g:=gcd(g,a[i]);
Writeln('НОД=',g)
end.
Пример
Введите 10 натуральных двухзначных чисел: 38 42 56 82 96 32 18 40 58 90
НОД=2
// Внимание! Если программа не работает, обновите версию!
function gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var a:=ReadArrInteger('Введите 10 натуральных двухзначных чисел:',10);
var g:=gcd(a[0],a[1]);
for var i:=2 to 9 do g:=gcd(g,a[i]);
Writeln('НОД=',g)
end.
Пример
Введите 10 натуральных двухзначных чисел: 38 42 56 82 96 32 18 40 58 90
НОД=2
Ответил Archibald0000
0
А начало можно программы?
Ответил Аноним
0
Это абсолютно полная программа. Можете запустить и убедиться
Новые вопросы
Литература,
2 года назад
История,
2 года назад
География,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад