Информатика, вопрос задал heart4545 , 9 лет назад

составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру

Ответы на вопрос

Ответил lNT64
0
program z1;
var a,b,c,d:integer;
procedure nod(x,y:integer;var nod2:integer);
begin
        while x<>y do begin
                if x>y then begin
                        x:=x-y
                end
                else begin
                        y:=y-x
                end
        end;
        nod2:=xend;
begin
        write('a=');readln(a);
        write('b=');readln(b);
        write('c=');readln(c);
        write('d=');readln(d);
        nod(a,b,b);
        nod(b,c,c);
        nod(c,d,d);
        writeln('nod=',d);
        readln
end.

Ответил heart4545
0
Спасибо.
Новые вопросы