Информатика, вопрос задал dimaa1011 , 7 лет назад

составить программу для нахождения корней с алгоритмом a, b, c
По вот этому алгоритму

Приложения:

Ответы на вопрос

Ответил hello93
0

program urav;

var

 a,b,c : integer;

 D,x,x1,x2:real;

begin

 writeln('Введите коэфиценты a, b, c');

 read(a, b, c);

 D:=sqr(b)-4*a*c;

 if D<0 then  

   writeln('Нет вещественных корней')

 else

   if D=0 then  

     begin

       x:=(-b)/2*a;

       writeln('Уравнение имеет один корень x=',x);

     end

   else

     begin

       x1:=((-b)-sqrt(D))/2*a;

       x2:=((-b)+sqrt(D))/2*a;

       writeln('уравнение имеет 2 корня x1=',x1,' x2=',x2);

     end;  

end.  

Новые вопросы