Информатика, вопрос задал vdovenich , 8 лет назад

Составить программу для нахождения элемента массива равного Заданному числу N. Число N Задается с клавиатуры массив состоит из 25 целых чисел заданных с клавиатуры.

Ответы на вопрос

Ответил estengseant
0
var a: array[0..25] of Integer;
b,i,n: integer;
begin
for i:=0 to 24 do
begin
writeln('Введите ',i+1,' число');
readln(b);
a[i]:=b;
end;
writeln('Какое число найти?');
readln(n);
for i:=0 to 24 do
begin
if a[i]=n then writeln('Число ',n,' - ',i,'-ый элемент в массиве');
end;
end.
Ответил allangarsk
0
в объявленном массиве 25 элемент лишьний
Ответил estengseant
0
От того, что я поставлю вместо числа 25 - число 24, программа по-другому не начнёт функционировать.
Ответил allangarsk
0
в этом я не сомневаюсь, прошу и мне всегда помогать с корректностью кода
Новые вопросы