Составить программу для нахождения для данного натурального числа сумму его чётных делителей
Ответы на вопрос
Ответил 13nijazi13
0
Ответ:
var
a,i,res: integer;
begin
writeln('Введите число');
readln(a);
for i:=1 to a do
begin
if i mod 2=0 then
begin
if a mod i=0 then res:=res+i;
end;
end;
writeln(res);
end.
Объяснение:
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
7 лет назад
Математика,
9 лет назад
Физика,
9 лет назад