Составить программу C ПОМОЩЬЮ ФУНКЦИИ(ПАСКАЛЬ), вычисляющую и выводящую 10 первых членов последовательности Фибоначчи
Ответы на вопрос
Ответил pinguinbird
1
Ответ:
function FibNum(a:longint):longint;
begin
if a <= 2 then FibNum:=1
else FibNum:=FibNum(a-1)+FibNum(a-2)
end;
var
i:integer;
begin
for i:=1 to 10 do write(FibNum(i), ' ')
end.
Вывод программы:
1 1 2 3 5 8 13 21 34 55
pinguinbird:
А в чём нарушение, можете, пожалуйста, объяснить? )
Новые вопросы
Русский язык,
2 года назад
Алгебра,
2 года назад
Қазақ тiлi,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад