Информатика, вопрос задал Asperinkaa , 8 лет назад

составить программу 10 первых натуральных чисел и их квадратов и кубов

Ответы на вопрос

Ответил GunWoman
0
program yoyo;
uses crt;
var a,b,c:array [1..10] of integer;i:integer;
begin
write('введите последовательные натуральные числа с 1: ');
for i:=1 to 10 do read(a[i]);
for i:=1 to 10 do begin b[i]:=sqr(a[i]);end;
for i:=1 to 10 do begin c[i]:=a[i]*a[i]*a[i];end;
for i:=1 to 10 do begin write('квадрат числа ',i,' = ', b[i]);writeln;end;
for i:=1 to 10 do begin write('куб числа ',i,' = ', c[i]);writeln;end;
end.
Приложения:
Новые вопросы