Информатика, вопрос задал ccuccumber , 1 год назад

Составить линейную программу для решения задачи.
Написать программу, которая выводит на экран первые три степени числа π. ​


enxt: языыыыыккккк
enxt: на французком?

Ответы на вопрос

Ответил enxt
0

program PowerOfPi;

var

 i: integer;

 power: real;

begin

 power := 1.0;

 for i := 1 to 3 do

 begin

   power := power * pi;

   writeln('π^', i, ' = ', power:0:6);

 end;

end.

Ответил honvert
1

Программа на Python:

import math

# Вычисление первых трех степеней числа π

pi_squared = math.pi ** 2

pi_cubed = math.pi ** 3

# Вывод результата на экран

print(pi_squared)

print(pi_cubed)

Программа на C++:

#include <iostream>

#include <cmath>

int main() {

 // Вычисление первых трех степеней числа π

 double pi_squared = pow(M_PI, 2);

 double pi_cubed = pow(M_PI, 3);

 // Вывод результата на экран

 std::cout << pi_squared << std::endl;

 std::cout << pi_cubed << std::endl;

 return 0;

}

Программа на C:

#include <stdio.h>

#include <math.h>

int main() {

 // Вычисление первых трех степеней числа π

 double pi_squared = pow(M_PI, 2);

 double pi_cubed = pow(M_PI, 3);

 // Вывод результата на экран

 printf("%.6lf\n", pi_squared);

 printf("%.6lf\n", pi_cubed);

 return 0;

}

Программа на Java:

public class Main {

 public static void main(String[] args) {

   // Вычисление первых трех степеней числа π

   double pi_squared = Math.pow(Math.PI, 2);

   double pi_cubed = Math.pow(Math.PI, 3);

   // Вывод результата на экран

   System.out.println(pi_squared);

   System.out.println(pi_cubed);

 }

}


ccuccumber: на паскале бы(
honvert: program PiPowers;

var
pi: real;

begin
pi := 3.14159265358979323846; // Значение числа π
writeln(pi:0:15, '^1 = ', pi:0:15); // Первая степень
writeln(pi:0:15, '^2 = ', pi*pi:0:15); // Вторая степень
writeln(pi:0:15, '^3 = ', pi*pi*pi:0:15); // Третья степень
end.
honvert: вот на паскале
ccuccumber: ОГРОМНОЕ СПАСИБО
Новые вопросы