Составить блок схему и написать программу
Задача: Ввести 10 значений в переменную Z . Найти и выдать на экран количество введеных нулей
.
Аноним:
А им не нужен ни массив, ни матрица, ни вектор. Нужна простая переменная для оператора Read(Z)
Вариант 1
<iostream.h>
void main(void){
int z,k=0;
for (int i = 0; i < 10; i++ ){
cout<<"press enter Z: "<<endl;
cin>>z;
if(z==0){k++;} }
cout<<"Количество нулей: "<<k; }
getch();}
Вариант 2
<iostream.h>
void main(void){
int z[10];
int k=0;
for (int i = 0; i < 10; i++ ){
cout<<"press enter Z: "<<endl;
cin>>z[i];
if(z==0){k++;} }
cout<<"Количество нулей: "<<k; }
getch();}
Ответы на вопрос
Ответил Merzik
0
var i,k:integer;
z:array[10] of integer;
for i:=0 to 10 do
read(z[i]);
k:=0;
for i:=0 to 10 do
if z[i]=0 then inc(k);
writeln('Нулей:', k);
end.
z:array[10] of integer;
for i:=0 to 10 do
read(z[i]);
k:=0;
for i:=0 to 10 do
if z[i]=0 then inc(k);
writeln('Нулей:', k);
end.
Приложения:

Ответил Аноним
0
var
i,k,z:integer;
begin
k:=0;
Write('Введите 10 целых чисел: ');
for i:=1 to 10 do
begin Read(z); if z=0 then Inc(k) end;
Writeln('Количество введенных нулей равно ',k)
end.
Тестовое решение:
Введите 10 целых чисел: 6 -5 0 4 -8 0 3 1 -2 0
Количество введенных нулей равно 3
Блок схема во вложении.
i,k,z:integer;
begin
k:=0;
Write('Введите 10 целых чисел: ');
for i:=1 to 10 do
begin Read(z); if z=0 then Inc(k) end;
Writeln('Количество введенных нулей равно ',k)
end.
Тестовое решение:
Введите 10 целых чисел: 6 -5 0 4 -8 0 3 1 -2 0
Количество введенных нулей равно 3
Блок схема во вложении.
Приложения:

Новые вопросы
Химия,
2 года назад
Математика,
2 года назад
Информатика,
2 года назад
Химия,
2 года назад
Математика,
7 лет назад