Информатика, вопрос задал ay0m3lld , 1 год назад

Составить блок схему и написать программу.
Объявить массив из 20 переменных.
Заполнить его случайными числами, большими 30 и меньшими 90.
Вывести массив.
Найти сумму и количество элементов, больших 40 и не превосходищих 60.
Вывести результат. Если таких элементов не оказалось, то вывести сообщение "таких элементов нет".

Ответы на вопрос

Ответил makason512
0

Блок-схема:

1. Объявить массив из 20 переменных

2. Заполнить массив случайными числами от 30 до 90

3. Вывести массив

4. Инициализировать сумму и количество элементов, больших 40 и не превосходищих 60

5. Перебрать все элементы массива

6. Если элемент больше 40 и не превосходит 60, то увеличить сумму и количество таких элементов

7. Если количество элементов больше 0, то вывести сумму и количество таких элементов

8. Иначе вывести сообщение "таких элементов нет"

программа

import random

array = []

for i in range(20):

 array.append(random.randint(30, 90))

print(array)

sum = 0

count = 0

for element in array:

 if element > 40 and element <= 60:

   sum += element

   count += 1

if count > 0:

 print("Сумма элементов:", sum)

 print("Количество элементов:", count)

else:

 print("Таких элементов нет")

Новые вопросы