Информатика, вопрос задал Egorushkaa , 9 лет назад

Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:

Вычислить
сумму положительных элементов матрицы А (10х10), расположенных над главной
диагональю. Индекс номера строки  i изменяется
от 1 до 9, а индекс номера столбца j изменяется от –i+1
до 10.

Ответы на вопрос

Ответил Vladiener
0
var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do 
 for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
 i:=np; 
 for j:=1 to np do begin 
  if a[i,j]>0 then sum:=sum+a[i,j]; 
  i:=i-1; 
 end;
end; 
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.
Новые вопросы