Информатика, вопрос задал s6773483 , 7 лет назад

Составь программный код к задаче

Пользователь с клавиатуры вводит номер месяца, а программа выводит на экран ответ, какое это время года...лето, весна, зима, осень.

Входные данные: номер месяца

Выходные данные: время года


vimmortal2: python?
s6773483: да

Ответы на вопрос

Ответил KennyLans
1

Язык программирования не сказан, писал на Паскале.

  • Program Brainy;
  • Var n:integer;
  • Begin
  • Write('Введите номер месяца: ');
  • Readln(n);
  • case n of
  • 3..5: Write('Весна');
  • 6..8: Write('Лето');
  • 9..11: Write('Осень');
  • 1,2,12: Write('Зима');
  • end;
  • end.
Приложения:
Ответил vimmortal2
5

Ответ:

Объяснение:

a = int(input('Введите номер месяца: '))

if a == 1 or a == 2 or a == 12:

print('Зима')

elif a == 3 or a == 4 or a == 5:

print('Весна')

elif a == 6 or a == 7 or a == 8:

print('Лето')

elif a == 9 or a == 10 or a == 11:

print('Осень')

Приложения:
Новые вопросы