Информатика, вопрос задал regressor04 , 2 года назад

Сортировка по сумме цифр
Напишите программу, которая сортирует натуральные числа в массиве по убыванию суммы цифр десятичной записи числа. При равенстве сумм цифр числа должны сохранить исходный порядок.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел — элементы массива. Гарантируется, что 0 
Выходные данные

Программа должна вывести в одной строке элементы массива, отсортированного в порядке убывания суммы цифр десятичной записи числа, разделив их пробелами.

Примеры
Ввод
Вывод
6
9 21 32 55 81 11
55 9 81 32 21 11
Решите на C++ или python

Ответы на вопрос

Ответил nekitoss
7

Ответ:

def main():

   n = int(input())

   a = input().split(maxsplit=n)

   a.sort(key=lambda x: sum(map(int, x)), reverse=True)

   print(*a)

if __name__ == "__main__":

   main()

Объяснение:

это python


12adelina: с++ помогите пожалуйста
lfif8549: Можно эту же задачу на С++?
nekitoss: Извините, я не знаю С++
lfif8549: А вы можете помочь с этой задачей?
Ровно К обменов
Даны два числа n и k. Вывести перестановку из n чисел (n чисел от 1 до n без повторений) такую, чтобы сортировка пузырьком по возрастанию на соответствующем массиве сделала ровно k обменов. Если возможных ответов несколько — выведите любой.
lfif8549: Я могу задать вопрос на зниниях с этим задание и еще двумя, вы поможете?
nekitoss: С этим заданием помогу если задашь вопрос с полным описанием задачи, там же по любому есть еще условия
12adelina: есть задание на питоне, помогите пожалуйста
12adelina: Сокращение дроби
Дана дробь ab. Требуется её сократить, то есть записать это же число в виде cd, где c — целое число, d — натуральное число и d минимальное возможное.

Входные данные

Вводятся два целых числа a и b (–100≤a≤100, 0
Выходные данные

Выведите два числа c и d.

Примеры
Ввод 1
18 27
Вывод
2 3
12adelina: нужно код на питоне написать
Новые вопросы