Информатика, вопрос задал Аноним , 10 лет назад


 сорочно !!!!!!!!Напишите программу которая в последовательности целых чисел определяет кол-во кратных 5 или 7 . программа получает на вход целые числ кол-во введеных чисел неизвестно последовальность чисел заканчивается число 0 ( 0 признак окончания ввода не входит в последовательность) ко-во чисел не превышает 1000 введеные числа по модулу не превышает 30 000 программа должна вывести оно число кол-во чисел кратных 5 или 7 пример работы 

- 22
25
-14
0
выходные данные 
2

Ответы на вопрос

Ответил archery
0
using System;


namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            var number = 0;
            int n;
            do {
                Console.WriteLine("Введите число");
                n = Convert.ToInt32(Console.ReadLine());
                if (n != 0 && (n % 5 == 0 || n % 7 == 0)) {
                    number++;
                }
            } while (n != 0);

            Console.WriteLine("Кол-во = " + number);

            Console.ReadKey();
        }
    }
}


Новые вопросы