Информатика, вопрос задал Никита105501 , 8 лет назад

Сложные условия ВЕТВЛЕНИЯ ПАСКАЛЬ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.

Пример:

Введите три числа:

5 5 5

Все числа одинаковые.

Пример:

Введите три числа:

5 7 5

Два числа одинаковые.

Пример:

Введите три числа:

5 7 8

Нет одинаковых чисел.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
  3:Writeln('Нет одинаковых чисел');
  2:Writeln('Два числа одинаковые');
  else Writeln('Все числа одинаковые')
  end
end.

Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые

Введите три целых числа: 5 7 5
Два числа одинаковые

Введите три целых числа: 5 7 8
Нет одинаковых чисел
Ответил NaaMan
0
Ув. Эникей, детишки изучают сложные ветвления, а вы предлагаете им 4 черных ящика :)
Ответил Аноним
0
CASE - это как раз сложное ветвление. Не путать с вложенными ветвлениями!
Новые вопросы