Информатика, вопрос задал Кристиночка937 , 8 лет назад

Скажите, пожалуйста, что неправильно в данной программе. Задание такое: Совершенным называется число, равное сумме всех своих делителей, меньших его самого (например, число 6 = 1 + 2 + 3). Напишите программу, которая вводит натуральное число N и определяет, является ли число N совершенным

Приложения:

Ответы на вопрос

Ответил petyaGavrikov
0
n = int(input())
s = 1
for i in range(2, n//2+1):
  if n % i == 0: s = s+i
if s == n:
  print("Совершенное")
else:
  print("Не совершенное")

Пример:
6
Совершенное
Новые вопросы