Система Паскаль.
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4.
Ответы на вопрос
Ответил huston81
2
Ответ:
pascal
Объяснение:
program summa;
var i, s: integer;
begin
WriteLn('Введите числа (или 0, чтобы закончить: ');
repeat
Write('i = ');
ReadLn(i);
if (i mod 3 = 0) and (i mod 10 = 4) then s := s + i;
until i = 0;
WriteLn('Сумма введенных натуральных чисел, кратных 3 и оканчивающихся на 4, равна ', s);
end.
helpmekillme:
Спасибо. Я лишь не понимаю, по какой причине программа не принимает вторую строчку var. Засчитывает как ошибку. о.0
Новые вопросы
Информатика,
2 года назад
Математика,
2 года назад
Математика,
2 года назад
Другие предметы,
2 года назад
Математика,
8 лет назад