Информатика, вопрос задал angella11 , 10 лет назад

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен произведению соответствующего элемента исходного массива и заданного с клавиатуры числа А. В проученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные полученные результаты.

Ответы на вопрос

Ответил Аноним
0
var
  m,n: array [1..15] of integer;
  a,i,max: integer;
begin
readln(a);
writeln('Исходный массив:');
for i:= 1 to 15 do
   begin
   m[i]:= random(20);
   n[i]:=m[i]*a;
   if (n[i]>max) and (i mod 2=1) then max:=n[i];
   write (m[i],'  ');
   end;
writeln;
writeln('Новый массив:');
for i:= 1 to 15 do  write (n[i],'  ');
writeln;
writeln('Максимальный нечетный: ',max);
end.
Новые вопросы