Информатика, вопрос задал pismecomashe , 2 года назад

Сделайте программу на Python пжжж:


Цирковая обезьянка еще не может быть полноценным игроком в Ним, но она обучена либо удваивать количество камней в куче, либо добавлять один.

Напишите программу, подсчитывающую минимальное количество действий, которые надо совершить обезьянке, чтобы получить кучу из n камней. Изначально в распоряжении циркачки всего один камень.
Формат ввода

Строка, содержащая число n - необходимое количество камней в куче.
Формат вывода

Число - необходимое количество шагов.
Пример 1
Ввод Вывод

11 5

Пример 2
Ввод Вывод

3 2

Ответы на вопрос

Ответил KekLolNope
11

Ответ:

n = int(input())

i = 0

while n != 1:

   if n % 2 == 0:

       n /= 2

   else:

       n -=1

   i += 1

print(i)

Приложения:

pismecomashe: Спасибо огромное))♪
Новые вопросы