Сделать на Pascal.Составить программу для вычисления функции, заданой графиком:
Приложения:

Ответы на вопрос
Ответил maya28dv
0
var y,xn,xk,s:real;
begin
readln(s,xn,xk);//s-шаг функции xn и xk - интервал иксов, в котором мы рассматриваем функцию
writeln('x',' ','y');
while xn<xk do begin
while xn<0 do begin y:=0; xn+=s; writeln(xn,' ',y); end;
while y<4 do begin y:=power(xn,2); xn+=s; writeln(xn,' ',y); end;
while xn<xk do begin y:=4; xn+=s; writeln(xn,' ',y); end;
exit;
end;
end.
begin
readln(s,xn,xk);//s-шаг функции xn и xk - интервал иксов, в котором мы рассматриваем функцию
writeln('x',' ','y');
while xn<xk do begin
while xn<0 do begin y:=0; xn+=s; writeln(xn,' ',y); end;
while y<4 do begin y:=power(xn,2); xn+=s; writeln(xn,' ',y); end;
while xn<xk do begin y:=4; xn+=s; writeln(xn,' ',y); end;
exit;
end;
end.
Ответил petyaGavrikov
0
var x,y:real;
begin
write('x = ');
readln(x);
if (x<-4)or(x>4)
then writeln('Функция не определена')
else begin
if x<0
then y:=0
else if x<2 then y:=x*x
else y:=4;
writeln('Y = ',y);
end;
end.
Пример:
x = 1.5
Y = 2.25
begin
write('x = ');
readln(x);
if (x<-4)or(x>4)
then writeln('Функция не определена')
else begin
if x<0
then y:=0
else if x<2 then y:=x*x
else y:=4;
writeln('Y = ',y);
end;
end.
Пример:
x = 1.5
Y = 2.25
Новые вопросы