С++
С использованием оператора switch () написать программу, которая будет выводить на экран: «Введи количество углов», затем считывать введенное с клавиатуры целое число и выводить на экран при соответствующем введенном значении одну из фраз: «Это треугольник», «Это четырехугольник», «Это пятиугольник», «Это многоугольник» или «Нет такого многоугольника»
Ответы на вопрос
Ответ:
#include "stdafx.h"
#include <iostream>
using namespace std;
int main(int argc, char* argv[])
{
int count; // переменная для выбора в switch
cout << " Введите число углов";
cin >> count;
switch (count) // начало оператора switch
{
case 3: // если count = 3
{
cout << " Это четырех угольник" << endl;
break;
}
case 4: // если count = 4
{
cout << "Это четырехугольник" << endl;
break;
}
case 5: // если count = 5
{
cout << "Это пятиугольник" << endl;
break;
}
case 4: // если count = 4
{
cout << a << " / " << b << " = " << a / b << endl;
break;
}
default: // если count равно любому другому значению
cout << "Нет такого многоугольника" << endl;
}
system("pause");
return 0;
}
Объяснение: