С++ пожалуйстааа
Х – номер месяца. Написать программу, которая выдает количество праздничных дней в этом месяце. Например, 1 – 3 дня, 2 – 0 дней, 3 –1 день, 4 – 0 дней, 5 – 3 дня, 6 – 1 день, 7,8,9,10 – 0 дней, 11 – 1 день, 12 – 2 дня.
Ответы на вопрос
#include <iostream>
using namespace std;
int main()
{
int month, holidays;
cout << "Введите номер месяца: ";
cin >> month;
switch (month) {
case 1:
holidays = 3;
break;
case 2:
holidays = 0;
break;
case 3:
holidays = 1;
break;
case 4:
holidays = 0;
break;
case 5:
holidays = 3;
break;
case 6:
holidays = 1;
break;
case 7:
holidays = 0;
break;
case 8:
holidays = 0;
break;
case 9:
holidays = 0;
break;
case 10:
holidays = 0;
break;
case 11:
holidays = 1;
break;
case 12:
holidays = 2;
break;
default:
cout << "Некорректный номер месяца!" << endl;
return 1;
}
cout << "Количество праздничных дней в " << month << "-м месяце: " << holidays << endl;
return 0;
}