Информатика, вопрос задал NasAnishenko777 , 10 лет назад

С ПОМОЩЬЮ ПАСКАЛЯ                 
Дана информация о температуре воздуха за январь. Написать программу, которая:
а)Определит сколько раз температура опускалась ниже 0 градусов
б)Определит среднюю температуру за январь



Ответы на вопрос

Ответил Аноним
0
var
   st:real;
   i,n:integer;
   t:array[1..31]of integer;
begin
writeln('Температура в январе:');
for i:=1 to 31 do
  begin  t[i]:=random(-10,5);
  write(t[i],' ');
  st:=st+t[i];
  if t[i]<0 then n:=n+1
  end;
st:=st/31;
writeln;
writeln('Число дней с отр.температурой: ',n);
writeln('Средняя температура: ',st:1:1)
end.
Ответил NasAnishenko777
0
а почему значение ср. температуры постоянно меняется?
Ответил Аноним
0
Чуток ошибся, единичка не пропечаталась)) Вот так надо: t[i]:=random(15)-10
Ответил Аноним
0
Ну мы же случайными числами заполняем (берем с "потолка"). А они при каждом запуске программы разные. Вот и среднее разное
Ответил Аноним
0
Заработала прога?
Новые вопросы