Информатика, вопрос задал beepbeeptrshm , 2 года назад

с помощью конструкции цикла while!!!!
Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число, превышающее введенное. Обязательно в тетради оформить таблицу входных и выходных данных.

Ответы на вопрос

Ответил nastikots
1

Ответ:

program Chernovik;

var a: integer;

begin

read(a);

if a mod 10 = 0 then a:=a+1;

while a mod 10 <> 0 do a:=a+1;

write(a)

end.

Объяснение:

картинка

Ввод числа

Если введено круглое число (последняя цифра числа равна 0), то увеличиваем его на 1, т.к. выведенное круглое число, должно превышать введённое

Цикл while: пока последняя цифра числа не равна 0, увеличиваем число на 1

Вывод числа

Приложения:
Новые вопросы