Информатика, вопрос задал yurik1 , 8 лет назад

С++ Нужно написать программу которая бы распознавала наличие определённого символа в строке, например точка, если да то вывести ответ да если нет-нет. Попробовал написать таким образом но оно не работает:
#include
using namespace std;
int main(int argc, char** argv)
{
setlocale (LC_CTYPE, "Russian");
char string[5];
cout<<"vveidte stroku";
gets(string);
if(string==".")
cout<<"da";
else cout<<"no";

system("pause");
return 0;
}

Ответы на вопрос

Ответил petyaGavrikov
0
#include <iostream>
using namespace std;

int main(int argc, char** argv) 
{
setlocale (LC_CTYPE, "Russian"); 
string s;
int n=0;
cout<<"vveidte strokun";
getline (cin, s);
n = s.find(".");
if(n>=0)
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}

Пример:
vveidte stroku
если да то вывести ответ да если нет-нет.
da
Новые вопросы