С++ Напишите программу, которая заполняет матрицу неотрицательными числами по диагоналям (см. пример). Значение элемента матрицы равно расстоянию от левого верхнего угла матрицы.
Входные данные
Во входной строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ).
Выходные данные
Программа должна вывести полученную матрицу по строкам.
Примеры
входные данные
4 5
выходные данные
0 1 2 3 4
1 2 3 4 5
2 3 4 5 6
3 4 5 6 7
Ответы на вопрос
Ответил Tvorobusheck
0
Вот сам код в комментарии, также прикрепил в виде файла:
Приложения:
Ответил Tvorobusheck
0
#include <iostream>
#include <conio.h>
using namespace std;
int main()
{
int n, m;
cout << "n=";
cin >> n;
cout << "m=";
cin >> m;
int** matrix = new int *[n];
for(int i = 0; i < n; i++)
matrix[i] = new int [m];
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
matrix[i][j]=i+j;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++)
cout << matrix[i][j] << " ";
cout << "n";
}
getch();
return 0;
}
#include <conio.h>
using namespace std;
int main()
{
int n, m;
cout << "n=";
cin >> n;
cout << "m=";
cin >> m;
int** matrix = new int *[n];
for(int i = 0; i < n; i++)
matrix[i] = new int [m];
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
matrix[i][j]=i+j;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++)
cout << matrix[i][j] << " ";
cout << "n";
}
getch();
return 0;
}
Новые вопросы
Қазақ тiлi,
2 года назад
Математика,
2 года назад
Химия,
9 лет назад
Математика,
9 лет назад
Физика,
9 лет назад