Информатика, вопрос задал OhmyyGod , 9 лет назад

С++ Напишите программу, которая выводит номера элементов массива, равных заданному значению X .

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке номера элементов массива, равных X , разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число -1.

Ответы на вопрос

Ответил eaststar94
0
#include<iostream>#include<stdlib.h>using namespace std;int main(){ int n,i,j=0,k; cin>>n;  int a[n]; for(i=0;i<n;i++) { cin>>a[i]; } int X; cin>>X; int W[n]; for(i=0;i<n;i++) { if(a[i]==X) { W[j]=i; j++; }   } for(i=0;i<j;i++) cout<<W[i]<<" ";}
Новые вопросы