Информатика, вопрос задал MAiklA , 8 лет назад

С++
Напишите программу, которая в четырехзначном числе меняет местами цифры сотен и десятков.
Вывести полученное число.
Ввод Вывод
1267 1627

Ответы на вопрос

Ответил clinteastwood2
0
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
using namespace std;
int main()
{
    int number; 
    cin >> number;
    number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
    cout << number;
}
Ответил clinteastwood2
0
Спасибо не забудьте сказать..
Новые вопросы