с++ Напишите программу, которая по полному списку номеров бракованных изделий, выдаст этот список в сокращенном виде.
В фирме, выпускающей компьютерные комплектующие, все изделия получают последовательные номера от 1 до N. Каждое изделие после его изготовления поступает в отдел контроля качества, где оно проверяется, и либо уходит в продажу, либо заносится в список бракованных изделий и списывается. К сожалению, список бракованных изделий иногда оказывается чересчур длинным. Тогда для его сокращения подряд идущие числа заменяются интервалом: через тире указываются номера первого и последнего изделия интервала.
Например, вместо 1,3,4,5,6,7,8,10,12,16,17,20,21,22,23,24
Записывается 1,3-8,10,12,16-17,20-24
Входные данные.
Вводится сначала число N - общее количество изделий. Затем число M - количество изделий, оказавшихся бракованными. Далее вводятся в возрастающем порядке номера бракованных изделий.
Выходные данные.
Выведите в одной строке список номеров бракованных изделий в сокращенном виде. Интервалы должны разделяться запятой. В строке не должно быть пробелов.
Ограничения 1≤M≤N≤1000000.
Пример
Вход Выход
10 5
1 3 5 7 9
1,3,5,7,9
40 16
1 3 4 5 6 7 8 10 12 16 17 20 21 22 23 24
1,3-8,10,12,16-17,20-24
Ответы на вопрос
Ответил maxpavlutenkof
0
#include <iostream>
using namespace std;
int main()
{
int num;
cin >> num >> num;
int* ans = new int[num];
for (int jjj = 0; jjj < num; jjj++) cin>> ans[jjj];
for (int jjj = 1; jjj < num; jjj++) {
if (ans[jjj - 1] != ans[jjj] - 1) cout << ans[jjj - 1] << ",";
else {
cout << ans[jjj - 1];
int kkk = jjj;
for (kkk; kkk < num; kkk++)
if (ans[kkk - 1] != ans[kkk] - 1) break;
if (kkk - jjj > 1) cout << "-" << ans[kkk - 1];
else cout << "," << ans[kkk - 1];
jjj = kkk;
if (num - jjj) cout << ",";
}
if (num - jjj == 1) cout << ans[jjj];
}
}
Ответил maxpavlutenkof
0
к тому же меня смущает то, что по условию мы вводи общее количество изделий ,а в решении оно никак не фигурирует
Ответил hinariyandere
0
может как-то переделать на вывод дефиса эту часть?
if (k - j > 1) cout << "-" << ans[k - 1];
else cout << "," << ans[k - 1];
if (k - j > 1) cout << "-" << ans[k - 1];
else cout << "," << ans[k - 1];
Новые вопросы