Информатика, вопрос задал nshamakov2610 , 7 лет назад

С++. Напишите программу, которая находит количество элементов, равных максимальному. Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Программа должна вывести количество элементов массива, равных максимальному.
Ввод
1
3
3
1
0
Вывод:
2


LymarIvan: программа обрабатывает массив из 1 элемента, а именно тройки
LymarIvan: последние три числа игнорирует
nshamakov2610: пж помоги
nshamakov2610: напиши код пж
LymarIvan: #include
using namespace std;
int main() {
int N, count=0;
long long max;
cin>>N;
long long array[10001];
for(int i=0; i cin>>array[i];
for(int i=0; i {
if(i==0)
max=array[i];
else if(array[i]>max)
max=array[i];
}
for(int i=0; i if(array[i]==max)
count++;
cout<}
LymarIvan: cout<
LymarIvan: cout < < count; в конце без пробелов
LymarIvan: и после #include надеюсь догадаешься что, почему-то пропускает слова
LymarIvan: короче
nshamakov2610: iostream

Ответы на вопрос

Ответил LymarIvan
0

#include <iostream>

using namespace std;

int main() {

   int N, count=0;

   long long max;

   cin>>N;

   long long array[10001];

   for(int i=0; i<N; i++)

       cin>>array[i];

   for(int i=0; i<N; i++)

   {

       if(i==0)

           max=array[i];

       else if(array[i]>max)

           max=array[i];

   }

   for(int i=0; i<N; i++)

       if(array[i]==max)

           count++;

   cout<<count;

}


LymarIvan: на скриншоте написано:"вводится последовательность целых чисел, оканчивающихся числом 0"
LymarIvan: есть разница?
nshamakov2610: https://znanija.com/task/45125730?answeringSource=feedPublic%2FhomePage%2F3
nshamakov2610: реши это
nshamakov2610: пж
nshamakov2610: это можешь не рашать
nshamakov2610: уже
LymarIvan: если что, код для задания со скрина, который ты кинул, вот здесь replit.com/join/twmtvsvypz-ivanlimar
nshamakov2610: прости я не то скинул
вот https://znanija.com/task/45125736?answeringSource=feedPublic%2FhomePage%2F8
nshamakov2610: пж можешь решить
Новые вопросы