С клавиатуры вводятся 10 чисел
Написать программу, которая определяет наименьшее и наибольшее. Pascal ABC
Ответы на вопрос
Ответил hello93
0
const
n=10;
type
mas = array [1..n] of real;
procedure search(massive : mas);
var j : integer;
max, min : real;
begin
max := 1;
min := 1;
for j:=1 to n do
begin
if massive[j] > max then
max := massive[j];
if massive[j] < min then
min := massive[j];
end;
writeln;
writeln('наибольший элемент: ', max);
writeln('наименьший элемент: ', min);
end;
var
i : integer;
a : mas;
begin
writeln('введите массив: ');
for i:=1 to n do
read(a[i]);
writeln('массив: ' );
for i:=1 to n do
write(a[i]:4);
search(a);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад
Химия,
9 лет назад
Математика,
9 лет назад