Информатика, вопрос задал nnnhhh3 , 10 лет назад

С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию заданного символа.

Ответы на вопрос

Ответил abc123art
0

паскаль:

 

uses crt;

var a,b:string; а-слово ,b-символ

i:integer; переменная для счета

begin

writeln ('Слово и символ');

readln (a,b);\ввод данных

 

for i:=1to length(a) do if copy (a,i,1)=b then writeln (i);\Копирование по порядку символов слова а  и сравнение каждого с символом b. Вывод ответа. Или ответов 

readkey;\если символы в слове повторяются

end.

 

 

Ответил ali07
0

program xxx;

var a,s : string;

   i:integer;

begin

   writeln ('Введите слово и символ-');

   readln (s,a);

   for i:=1 to length(a) do

     if copy (s,i,1)=a then writeln (i);

   readln

end.

 

Новые вопросы