С клавиатуры вводится n чисел. Написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. Значение n также вводится с клавиатуры. Язык С++
Ответы на вопрос
Ответил Аноним
0
#include<iostream>
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}
Новые вопросы