Информатика, вопрос задал kam6667128 , 7 лет назад

С++ даю сто баллов напишите программу которая выводит последнее слово в строке

Ответы на вопрос

Ответил boda46537
0

Ответ:

using namespace std;

 

 

int main()

{

 string str,tmp;

 getline(cin,str);

 reverse(str.begin(),str.end());

 for(auto&i:str)

 {

   if(i==' ') {break;}

   tmp+=i;

 }

 str.clear();

 reverse(tmp.begin(),tmp.end());

 str=tmp;

 cout<<str<<endl;

 

 system("pause");

}

Объяснение:

надеюсь правильно понял


kam6667128: Спасибо,а можно как нибудь заменить reverse?просто мы этого ещё не проходили может for как нибудь?
Новые вопросы