Информатика, вопрос задал wokep , 7 лет назад

с++
Даны два массива a и b одинаковой длины n. Создать новый массив длины 2n, в котором все элементы с чётными индексами заимствуются из массива a, а с нечётными индексами из b.

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) — размер массивов. Во второй и третьей строках вводятся по n элементов массивов через пробел. Все элементы не превосходят по модулю 100000.

Формат выходных данных
Необxодимо вывести 2n элементов нового массива.
входные данные
5
1 2 3 4 5
5 4 3 2 1
выходные данные
1 5 2 4 3 3 4 2 5 1

Ответы на вопрос

Ответил aanni4
0

Ответ:  держи

#include <iostream>

using namespace std;

int main()

{

int n, i;

cout << "n = ";

cin >> n;

int a[n], b[n], c[2 * n], ac = 0, bc = 0;

cout << "введите а: ";

for (i = 0; i < n; i++) {

cin >> a[i];

}

cout << "введите b: ";

for (i = 0; i < n; i++) {

cin >> b[i];

}

cout << endl;

for (i = 0; i < 2 * n; i++) {

if (i % 2 == 0) { // парное

c[i] = a[ac];

ac++;

}

else { // непарное

c[i] = b[bc];

bc++;

}

cout << c[i] << ' ';

}

return 0;

}

Новые вопросы