Реверс массива
Напишите программу, которая выполняет реверс массива: меняет местами первый и последний элементы, второй и предпоследний и т.д.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
Примеры
входные данные:
6
1 2 3 4 5 6
выходные данные:
6 5 4 3 2 1
ОБЯЗАТЕЛЬНО c++
Ответы на вопрос
Ответил lozromanik
1
Відповідь:
#include<iostream>
int main(){
int N;
std::cin>>N;
int* massif = new int[N];
for(int i=0;i<N;i++) std::cin>>massif[i];
for(int i=N-1;i>=0;i--) std::cout<<massif[i]<<" ";
delete[]massif;
}
Новые вопросы