Решите задачу по программированию
Как мы знаем шоколадки дарят только тем, кто хорошо прошел IQ тест. Поэтому в детском саду №603075 решили подарить 228 грамм шоколада каждому ребенку, кто набрал не менее X баллов за тест. Шоколад продаётся плитками по 1337 грамм. Плитка ломается на кусочки по 228 грамм и эти кусочки раздаются детям. Остаток не выбрасывается и учитывается в следующем подарке. Определите сколько детей получат награду и сколько плиток шоколада для этого необходимо приобрести.
Формат ввода
В первой строке вводится N, X (1 <= N <= 105, 1 <= X <= 109) — количество детей и необходимый минимальный результат теста. В следующей строке вводится N целых положительных чисел не превышающих 109 — результаты теста.
Формат вывода
Выведите два числа — количество заслуженных обладателей кусочков шоколада и количество необходимых плиток шоколада.
Ответы на вопрос
Ответил raf1O5
0
program raf105;
var iq,n,x,i,choco,choco_counter,kid_counter: integer;
begin
write('Введите количество детей в детском саду: ');
readln(n);
write('Введите желаемый IQ: ');
readln(x);
writeln('Вводите IQ ',n,' детей по очереди.');
for i:=1 to n do
begin
readln(iq);
if iq >= x
then begin
if choco div 228 < 1
then begin
choco_counter+= 1;
choco+= 1337;
end;
choco-= 228;
kid_counter+= 1;
end;
end;
writeln('Награду получат ',kid_counter,' дет.');
writeln('Шоколада потребуется приобрести: ',choco_counter,' плит.');
end.
PascalABC 3.4.2
Ответил snaiper2281
0
3 и 1 точнее
Ответил csharp
0
Ну, так и есть.
Ответил csharp
0
Введите количество детей в детском саду: 6
Введите желаемый IQ: 97
Вводите IQ 6 детей по очереди.
96
99
95
98
99
91
Награду получат 3 дет.
Шоколада потребуется приобрести: 1 плит.
Введите желаемый IQ: 97
Вводите IQ 6 детей по очереди.
96
99
95
98
99
91
Награду получат 3 дет.
Шоколада потребуется приобрести: 1 плит.
Ответил snaiper2281
0
Подождите
Ответил snaiper2281
0
Ещераз перепроверю
Новые вопросы
Другие предметы,
2 года назад
Математика,
7 лет назад
Информатика,
7 лет назад
Математика,
9 лет назад
Литература,
9 лет назад