Информатика, вопрос задал Gleb0032 , 7 лет назад

РЕШИТЕ ЗАДАЧУ НА ПИТОНЕ ПЖЖЖ
ОЧЕНЬ СРОЧНО
Даны два четырёхзначных числа A и B. Выведите все четырёхзначные числа на отрезке от A до B, запись которых является палиндромом.

Входные данные
Вводятся два целых числа A и B

Выходные данные
Выведите ответ на задачу.

Примеры
входные данные
1600
2100
выходные данные
1661
1771
1881
1991
2002

Ответы на вопрос

Ответил LegendaryGhost
0

input1 = input()

input2 = input()


def test(x):

 x1 = x / 1000;

 x2 = x / 100 % 10;

 x3 = x / 10 % 10;

 x4 = x % 10;

 

 if x1 == x4 and x2 == x3:

   return x;

 else:

   return -1;


while input1 < input2:

 x = test(input1);

 if x != -1:

   print(x);

 input1 = input1 + 1;

Новые вопросы