Информатика, вопрос задал bokhanlena , 10 лет назад

Решите задачи:

1) Введите элементы массива а[1..10] с клавиатуры и вычислите количество элементов с четными положительными значениями.

2) Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15. 

 заранее спасибо за решение.

Ответы на вопрос

Ответил Megacoocker
0
1)
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i,cou:integer;
begin
clrscr;
  for i:=1 to 10 do
  begin
    write('Itput arr[',i,'] ');readln(arr[i]);
    if (arr[i]>0) and (arr[i] mod 2 = 0) then cou:=cou+1;
  end;
  writeln(cou);
end.

2)Тут вообще можно 1 циклом обойтись, но так не надо заворачиваться с перетаскиванием курсора.
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i:integer;
begin
  randomize;
  clrscr;
  for i:=1 to 10 do
    begin
      arr[i]:=random(20)+1;
      write(arr[i],' ');
    end;
  writeln;
  for i:=1 to 10 do
    if (arr[i]>5) and (arr[i]<15) then write(arr[i],' ');
end.



Приложения:
Новые вопросы