Информатика, вопрос задал mOri075 , 2 года назад

РЕШИТЕ ЯЗЫКОМ PYTHON
Остатки
Даны целые неотрицательные числа a, b, c, d, при этом 0≤c
В этой задаче нельзя использовать инструкцию if, операторы сравнения (< и т.д.), должен быть только один цикл.

Входные данные

На вход подаются четыре строки, в каждой из которых написано по одному неотрицательному целому числу — a, b, c, d. Все числа не превосходят 2∗109, 0≤c
Выходные данные
2
5
0
2
Вывыводные данные
2 4


bilanovfatim: а какое собственно задание?
mOri075: ты рофлишь

Ответы на вопрос

Ответил ulgorba4eva42
14

Ответ:

a=int(input())

b = int(input())

c = int(input())

d = int(input())

start= (a-c+d-1)//d*d+c

for i in range(start,b+1,d):

   print(i)

Объяснение:

Новые вопросы