Информатика, вопрос задал 1Николь , 10 лет назад

решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.

Ответы на вопрос

Ответил Sky09
0
uses crt;
const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
                                               11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
    U,x:integer;
    SUM:real;
begin
     write('U='); readln(U);
     for x:=1 to 20 do
     begin
         write('R[',x,']:',R[x],' ');
         I[x]:=U/R[x];
         SUM:=SUM+I[x];
         writeln('I[',x,']:',I[x]:5:3);
     end;
     writeln('I=',SUM:5:3);
end.
Новые вопросы