РЕШИТЕ В JAVA, ПОЖАЛУЙСТА. Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0). Числа, следующие за числом 0, считывать не нужно. Формат входных данных Вводится последовательность целых чисел, заканчивающаяся числом 0. Формат выходных данных Выведите ответ на задачу. Sample Input: 1 7 9 0 5 Sample Output: 3
Ответы на вопрос
Ответил DNHelper
2
import java.util.Scanner;
public class Main
{
public static void main(String[] args) {
int counter = 0;
Scanner scanner = new Scanner(System.in);
int num = scanner.nextInt();
while (num != 0) {
counter++;
num = scanner.nextInt();
}
System.out.println(counter);
scanner.close();
}
}
Новые вопросы
Русский язык,
2 года назад
Қазақ тiлi,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Биология,
8 лет назад
Математика,
8 лет назад