РЕШИТЕ СРОЧНО ЗАДАЧИ ПО С++!!!!!!!!!!!
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа.
Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.
Формат выходных данных
Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.
входные данные
3
5 -3 0
выходные данные
5 0
Grey0808:
Почему не на Python'e
Ответы на вопрос
Ответил gbsnat
0
#include <iostream>
#include <cmath>
using namespace std;
signed main(){
int n, x;
cin >> n;
while(n--){
cin >> x;
if(x == abs(x))
cout << x << " ";
}
}
Новые вопросы
Русский язык,
2 года назад
Другие предметы,
2 года назад
Физика,
2 года назад
Математика,
2 года назад
Химия,
8 лет назад