Информатика, вопрос задал mOri075 , 2 года назад

решите сегодня пж на языке python

Совпадающие начало и конец
Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них.

Входные данные

На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов.

Выходные данные

Выведите ответ на задачу.

Ответы на вопрос

Ответил dnmukha
6

Ответ:

s = input()

ans = ''

for i in range(len(s)):

   j = s.rfind(s[i]) + 1

   if j - i > len(ans):

       ans = s[i:j]

print(ans)

Новые вопросы